SHARE

Dev Team has launched new untethered jailbreak tools for newly released iOS 4.3.1. Earlier, only tethered jailbreak method was available as mentioned in my last post ‘Must Read before you Install, Jailbreak and Unlock‘.

This new 4.3.1 exploit was researched and found by Stefan Esser (@i0n1c). Stefan has been studying and working on various vulnerability research.

 

Which Devices are supported for iOS 4.3.1 Untethered Jailbreak?

This is a list of devices supported by this new version of the untethered jailbreak for being 4.3.1.

  • iPhone 3GS
  • iPhone 4 (GSM)
  • iPod touch 3G
  • iPod touch 4G
  • iPad 1
  • Apple TV 2G (PwnageTool only for now)

Devices like iPhone 4 (CDMA) and iPad 2 are not supported by this untethered jailbreak. IPad 2 requires a boot level to exploit this to work and limera1n & SHAtter exploits are patched by Apple in iPad 2.

Can I use ultrasn0w to unlock with untethered jailbreak for 4.3.1?

NO. Ultran0w is not currently compatible to unlock the devices on older bootrom and hence current version is not yet updated in Cydia to support unlock on 4.3.1. Ultrasn0w needs more testing & changes to be able to unlock all devices or continue using unlocked devices on older bootrom devices.

So, people using Ultrasn0w to unlock devices should wait for further updates from the Dev Team before they install or jailbreak 4.3.1. Here is what @MuscleNerd posted on twitter

Should I use Redsn0w 0.9.6 RC9 to jailbreak 4.3.1?

I would again say ‘Wait’ before you install or jailbreak your device on 4.3.1 with Redsn0w or PwnageTool. Unlock is not yet available and Redsn0w is only just released so I would really like to wait further more to see if any issues are coming up on different devices or not.

If your device is working fine & if you are happy with it, wait for a few days more before you try your hands on installing, jailbreaking & unlocking 4.3.1. I will post again when it’s the right time to upgrade without messing up too much with your iPhone.

6th April 2011 Update #1: Ultrasn0w Issues for 4.3.1

They have found and the great Dev-Team members have already fixed Signal bar issues with Ultrasn0w unlock on 4.3.1 on older baseband devices. It is under rigorous testing now and will be made available very soon.

The 4.3.1 issues (signal bars, etc) are fixed http://twitpic.com/4hcs1v but need a few days to test all devices + FW (again: not a new unlock!)

Update #2: Ultrasn0w for 4.3.1

Today @MuscleNerd posted in his latest tweet about Ultrasn0w update about 4.3.1 for existing unlock users

4.3.1-compat Ultrasn0w update for *current unlockers* is out to external testers. Barring any hiccups, release is tonight

I shall update you again soon on 4.3.1 Ultrasn0w Unlock.

Update #3

As mentioned above, Ultrasn0w update is now available on Cydia under it’s repo. Great work again by the Dev Team members.

20110410-145146.jpg

Buzz me if you have any queries.